Requirements

스프링 다이내믹 모듈(DM) 1.0은 JDK 1.4 이상과 OSGi R4 이상을 지원한다.

스프링 DM을 사용해서 배포하는 번들은 반드시 MENIFEST.MF에 “Bundle-ManifestVersion: 2″라고 명시해야 한다.

저게 무슨 뜻이냐면, OSGi R4를 따르는 번들이라는 뜻이다. 스프링 DM이 OSGi R4 이상을 지원하니까 저렇게 해야한다. 2 말고 1이라고 할 수도 있는데 그건 OSGi R3 스펙을 따르는 번들이라는 뜻이다.

스프링 DM은 Continuous Integration의 일부로 Equinox 3.2.2, Felix 1.0.3, Knopflerfish 2.0.4에서 테스트를 한다고 합니다. 멋있어!